Cisco Router-Konfiguration „Befehle/Commands“ deutsch
Die wichtigsten Befehle zur Routerkonfiguration mit Erläuterung.
Router (Standardkommando vor Verlassen) | |
copy running-config startup-config | Kopiert Konfiguration aus RAM in FLASH |
Hostname | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#hostname Router1 | Setzt den Hostnamen |
Telnet-Passwort | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#line vty 0 4 | Wechselt zu den Telnet Lines 0 bis 4 |
(config-line)#password tel_pw | Setzt das Telnet Kennwort |
(config-line)#login | Aktiviert die Kennwortabfrage |
Konsolen-Passwort | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#line console 0 | Wechselt zum Konsolenzugang |
(config-line)#password con_pw | Setzt das Konsolenkennwort |
(config-line)#login | Aktiviert die Kennwortabfrage |
Enable Password & Secret | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#enable password cisco1 | Setzt das unverschlüsselte Enable Kennwort |
(config)#enable secret cisco | Setzt das verschlüsselte Enable Secret |
Benutzer anlegen | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#username NUTZER password PW | Legt NUTZER mit Kennwort PW an |
SSH | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#ip domain-name domä.ne | Erzeugt den Domänennamen domä.ne |
(config)#line vty 0 4 | Wechselt zu den vty lines 0 bis 4 |
(config-line)#login local | Lokale Nutzer und Kennworte werden verwendet |
(config-line)#transport input telnet ssh | Aktiviert den SSH und Telnet Zugang auf den VTYs |
(config-line)#exit | Verlässt das Submenü |
(config)#crypto key generate rsa | Aktiviert SSH und erzeugt ein RSA Schlüsselpaar |
DNS Nutzung | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#no ip domain-lookup | Deaktiviert DNS Anfragen |
ODER | |
(config)# ip domain-lookup | Aktiviert DNS Anfragen |
Kennwortverschlüsselung | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#service password-encryption | Gesetzte und zukünftige Kennworte werden verschlüsselt hinterlegt |
ODER | |
(config)#no service password-encryption | Kennworte werden unverschlüsselt hinterlegt |
HTTP aktivieren (CMD/SMD) | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#ip http server | Aktiviert den HTTP-Server auf dem Gerät |
(config)#ip http server secure | Aktiviert den Secure HTTP-Server (SSL) auf dem Gerät |
Show Befehle | |
>enable | Wechselt in den privileged mode |
#show running-config | Zeigt die aktuelle Konfiguration |
#show version | Zeigt die aktuelle IOS Version |
#show users | Zeigt angemeldete Nutzer |
#show sessions | Zeigt aktive Sitzungen |
#show cdp | CDP Status Informationen |
#show cdp traffic | CDP Traffic Informationen |
#show cdp neighbors | CDP Nachbar Informationen |
#show cdp entry | CDP Geräte Eintrag |
#show cdp interface | CDP Interface Informationen |
#show ip interface brief | Liefert einen globale Überblick über die Interfaces |
#show ip interface status | Liefert eine Statusübersicht der Interfaces |
#show ip interface fastethernet 0/1 | Zeigt Informationen zum Interface fastethernet 0/1 |
#show ip route | Zeigt die Routing-Tabelle an |
#show ip protocols | Zeigt Routing Informationen |
Interfacekonfiguration | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#interface fa 0/1 | Wechselt zum Interface Fastethernet 0/1 |
(config-if)#ip add 192.168.11.2 255.255.255.0 | Definiert IP-Adresse auf Interface |
(config-if)#no shutdown | Aktiviert das Interface |
(config-if)#exit | Eine Ebene abwärts |
(config)#interface serial 0/1 | Wechselt zum seriellen Interface 0/1 |
(config-if)#ip add 192.168.12.2 255.255.255.0 | Definiert IP-Adresse auf Interface |
(config-if)#encapsulation hdlc | Setzt das Protokoll der seriellen Schnittstelle auf HDLC* |
ODER | * Ist Standard |
(config-if)#encapsulation ppp | Setzt das Protokoll der seriellen Schnittstelle auf PPP** |
ODER | **Weitere Konfigurationsschritte möglich |
(config-if)#encapsulation frame-relay | Setzt das Protokoll der seriellen Schnittstelle auf Frame-Relay*** |
***Weitere Konfigurationsschritte nötig | |
(config-if)#clock rate 64000 | Setzt die Leitungsgeschwindigkeit auf DCE-Seite auf 64 KBps |
(config-if)#bandwith 128 | Setzt die Bandbreiteninformation auf 128 KBps |
(config-if)#no shutdown | Aktiviert das Interface |
Subinterfaces | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#interface fa 0/1.1 | Wechselt zum SubInterface Fastethernet 0/1.1 |
(config-subif)#encapsulation dot1Q 1 | Definiert Trunkart 802.1Q und VLAN ID auf Subinterface |
ODER | |
(config-subif)#encapsulation isl 1 | Definiert Trunkart ISL und VLAN ID auf Subinterface |
(config-subif)#ip add 192.168.11.2 255.255.255.0 | Definiert IP-Adresse auf Interface |
*no shutdown wird auf HauptInterface gesetzt | |
Frame-Relay | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#interface serial 0/1 | Wechselt zum seriellen Interface 0/1 |
(config-if)#ip add 192.168.12.2 255.255.255.0 | Definiert IP-Adresse auf Interface |
(config-if)#encapsulation frame-relay | Setzt das Protokoll der seriellen Schnittstelle auf Frame-Relay+B226 |
(config-if)#frame-relay interface-dlci 476 | Definiert DLCI 476 auf diesem Interface |
(config-if)#frame-relay map ip 192.168.101.10 499 broadcast | Bindet Remote IP an DLCI und verteilt BC Informationen |
(config-if)#no shutdown | Aktiviert das Interface |
PPP | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#interface serial 0/1 | Wechselt zum seriellen Interface 0/1 |
(config-if)#ip add 192.168.12.2 255.255.255.0 | Definiert IP-Adresse auf Interface |
(config-if)#encapsulation ppp | Setzt das Protokoll der seriellen Schnittstelle auf PPP |
(config-if)#ppp authentification pap | Aktiviert PAP |
(config-if)#ppp pap sent-username NUTZER password PW | Definiert PAP Benutzerauthentifikation |
ODER | |
(config-if)#ppp authentification chap | Aktiviert CHAP |
(config-if)#ppp multilink | Aktiviert Multilink |
(config-if)#no shutdown | Aktiviert das Interface |
Statische Routen | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#ip route 10.20.30.0 255.255.255.0 192.168.0.17 | Definiert Route in 10.20.30.0 Netz über Next-Hop 192.168.0.17 |
ODER | |
(config)#ip route 10.20.30.0 255.255.255.0 serial 0/0 | Definiert Route in 10.20.30.0 Netz über Ausgangsinterface s0/0 |
Gateway of last resort | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.17 | Setzt die Default Route |
ODER | |
(config)#ip default-network 192.168.0.17 | Setzt die Default Route |
RIP | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#router rip | Aktiviert RIP und wechselt ins Router-Submenü |
(config-router)#network 12.0.0.0 | Fügt das Netzwerk zu RIP hinzu (Classfull) |
(config-router)#network 172.16.0.0 | Fügt das Netzwerk zu RIP hinzu (Classfull) |
RIP Version 2 | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#router rip | Aktiviert RIP und wechselt ins Router-Submenü |
(config-router)#version 2 | Aktiviert RIPv2 |
(config-router)#network 12.0.0.0 | Fügt das Netzwerk zu RIP hinzu (Classfull) |
(config-router)#network 172.16.0.0 | Fügt das Netzwerk zu RIP hinzu (Classfull) |
RIP Show Befehle | |
>enable | Wechselt in den privileged mode |
#show ip rip database | Zeigt die RIP Datenbank |
#debug ip rip | Zeigt RIP Aktivitäten in Echtzeit |
OSPF | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#router OSPF 4711 | Aktiviert OSPF, vergibt PID 4711 und wechselt ins Router-Submenü |
(config-router)#network 12.0.0.0 0.0.255.255 area 1 | Fügt das 12.0.0.0 /16 Netz zur OSPF Area 1 hinzu |
(config-router)#network 172.20.0.0 0.0.0.255 area 1 | Fügt das 172.20.0.0 /24 Netz zur OSPF Area 1 hinzu |
(config-router)#no auto-summary | Deaktiviert die Autosummary Funktion |
(config-router)#exit | Eine Ebene abwärts |
(config)#interface fa 0/1 | Wechselt zum Interface Fastethernet 0/1 |
(config-if)#ip ospf cost 25 | Definiert OSPF Kosten von 25 (max 65535) |
(config-if)#ip ospf hello-interval 3 | Definiert OPSF Hello-Interval 3 Sekunden |
(config-if)#ip ospf dead-interval 12 | Definiert OSPF Dead-Interval 12 Sekunden |
(config-if)#ip ospf priority 17 | Setzt die OSPF Priorität auf 17 (0-255 ist möglich) |
(config-if)#ip ospf authentication message-digest | Setzt & aktiviert OSPF Authentifikation auf MD verschlüsselt |
ODER | |
(config-if)#ip ospf authentication | Setzt & aktiviert OSPF Authentifikation ohne MD |
(config-if)#ip ospf authentication-key bis8zeic | Nicht-MD-Kennwort wird gesetzt (8 Zeichen Maximal) |
ODER | |
(config-if)#ip ospf message-digest-key 6 md5 bis16zeichen | MD Kennwort mit Key ID 6, MD5 verschlüsselung wird gesetzt |
OSPF Troubleshooting Befehle | |
>enable | Wechselt in den privileged mode |
#show ip ospf | Zeigt Grundlegende Infos zu OSPF |
#show ip ospf interface | Zeigt OSPF Infos aller Interfaces |
#show ip ospf interface fastethernet 0/0 | Zeigt OSPF Infos dieses Interfaces |
#show ip ospf border-routers | Zeigt ABR Informationen |
#show ip ospf neighbor | Listet alle Nachbarn auf |
#show ip ospf neighbor detail | Detailierte Liste der Nachbarn |
#show ip ospf database | Zeigt die OSPF Datenbank |
#clear ip route * | Löscht die gesamte Routing Tabelle |
#clear ip route 10.0.0.0 | Entfernt die Route aus der Routing Tabelle |
#clear ip ospf process | Leert den OSPF Prozess komplett (Nachbarn,Topologie, Routing) |
EIGRP | |
>enable | Wechselt in den privileged mode |
#conf t | Wechselt in den globalen Konfigurationsmodus |
(config)#router eigrp 2 | Aktiviert EIGRP, setzt die AS 2 und wechselt ins Router-Submenü |
(config-router)#network 12.0.0.0 0.0.255.255 | Fügt das Netz zu EIGRP hinzu |
(config-router)#network 172.20.0.0 0.0.0.255 | Fügt das Netz zu EIGRP hinzu |
(config-router)#no auto-summary | Deaktiviert die Autosummary Funktion |
EIGRP Troubleshooting | |
>enable | Wechselt in den privileged mode |
#show ip eigrp neighbors | Zeigt Infos zu EIGRP Nachbarn |
#show ip eigrp topology | Zeigt EIGRP Topologie |
#show ip eigrp interfaces | Zeigt alle EIGRP Interfaces |
#show ip eigrp interfaces 5 | Zeigt alle EIGRP Interfaces aus AS 5 |
#show ip eigrp traffic | Zeigt EIGRP Traffic Infos |
#debug eigrp packet | Zeigt Echtzeitinformationen zu EIGRP Paketen |
#debug eigrp neighbor | Zeigt Echtzeitinformationen zu EIGRP Nachbarn |
Standard ACL | |
>enable | Wechselt in den privileged mode |
#configure terminal | Wechselt in den globalen Konfigurationsmodus |
(config)#access-list 2 deny host 10.1.2.1 | Definiert ACL 2 (standard) Verbot für Host 10.1.2.1 |
(config)#access-list 2 permit any | Umgeht deny any welches automatisch gesetzt wird |
(config)#interface ethernet 0 | Wechselt zum Interface |
(config-if)#ip access-group 2 in | Bindet die ACL in eingehende Richtung an Interface |
Extended ACL | |
>enable | Wechselt in den privileged mode |
#configure terminal | Wechselt in den globalen Konfigurationsmodus |
(config)#access-list 102 deny tcp host 10.1.2.1 any eq tftp | Definiert ACL 102 (ext) TFTP Verbot für Host 10.1.2.1 |
(config)#access-list 102 deny tcp host 10.1.2.1 any eq 80 | Definiert ACL 102 (ext) HTTP Verbot für Host 10.1.2.1 |
(config)#access-list 102 permit ip any any | Umgeht deny any any welches automatisch gesetzt wird |
(config)#interface ethernet 0 | Wechselt zum Interface |
(config-if)#ip access-group 102 in | Bindet die ACL in eingehende Richtung an Interface |
Named ACL | |
>enable | Wechselt in den privileged mode |
#configure terminal | Wechselt in den globalen Konfigurationsmodus |
(config)#ip access-list extended ERNA | Erstellt eine Extended ACL mit Namen ERNA, wechsel in Submenü |
(config-ext-nacl)#deny tcp host 10.1.2.1 any eq 80 | Verbietet Host Zugriff auf HTTP |
(config-ext-nacl)# permit ip any any | Umgeht deny any any welches automatisch gesetzt wird |
(config-ext-nacl)#exit | Eine Ebene abwärts |
(config)#interface ethernet 0 | Wechselt zum Interface |
(config-if)#ip access-group ERNA in | Bindet die ACL in eingehende Richtung an Interface |
NAT | |
Standardbefehle | |
>enable | Wechselt in den privileged mode |
#configure terminal | Wechselt in den globalen Konfigurationsmodus |
(config)# interface ethernet 0 | Wechselt zum Interface |
(config-if)# ip nat inside | Definiert Interface als Inside Interface |
(config-if)# exit | Eine Ebene abwärts |
(config)# interface serial 1 | Wechselt zum Interface |
(config-if)# ip nat outside | Definiert Interface als Outside Interface |
>enable | Wechselt in den privileged mode |
# show running-config | Zeigt aktuelle Konfiguration |
# show ip nat translations | Zeigt NAT übersetzungen |
# show ip nat statistics | Zeigt NAT Statistiken |
#clear ip nat translations * | Leert die gesamte NAT Tabelle |
#clear ip nat translations inside IP outside IP | Leert die NAT Tabelle entfernt bestimmte in/out IP |
Statisches NAT- | eine private IP wird in genau eine öffentliche IP übersetzt |
>enable | Wechselt in den privileged mode |
#configure terminal | Wechselt in den globalen Konfigurationsmodus |
(config)# ip nat inside source static 172.16.0.100 72.21.0.100 | Übersetzt 172.16.0.100 privat in 72.21.0.100 öffentlich |
(config)# ip nat inside source static 172.16.0.105 72.21.0.105 | Übersetzt 172.16.0.105 privat in 72.21.0.105 öffentlich |
… | … |
(config)# ip nat inside source static 172.16.0.110 72.21.0.110 | Übersetzt 172.16.0.110 privat in 72.21.0.110 öffentlich |
Dynamisches NAT- | ein Gruppe privater IPs auf POOL öffentlicher IPs übersetzen |
>enable | Wechselt in den privileged mode |
#configure terminal | Wechselt in den globalen Konfigurationsmodus |
(config)# access-list 1 permit 172.16.0.0 0.0.255.255 | Welche Gruppe von privaten IPs wird genattet (Standard ACL) |
(config)# ip nat pool N_POOL 72.21.0.100 72.21.0.105 netmask 255.255.0.0 | Einen Pool an öffentlichen IPs definieren |
(config)# ip nat inside source list 1 pool N_POOL | Verbinden von privater Gruppe mit öffentlichem Pool |
overloading NAT with PAT- | eine Gruppe von privaten IPs wird auf eine öffentliche IP übersetzt |
>enable | Wechselt in den privileged mode |
#configure terminal | Wechselt in den globalen Konfigurationsmodus |
(config)# access-list 1 permit 172.16.0.0 0.0.255.255 | Welche Gruppe von privaten IPs wird genattet (Standard ACL) |
(config)# ip nat inside source list 1 interface S1 overload | Verbinden von privater Gruppe mit OUTSIDE INTERFACE |
Cisco Router-Konfiguration „Befehle/Commands“
I’ve recently started a blog, the information you provide on this site has helped me tremendously. Thank you for all of your time & work.
Really nice post,thank you
Useful blog website, keep me personally through searching it, I am seriously interested to find out another recommendation of it.
nice post. thanks.
Nice Post
Wahninnig guter Beitrag von ihrer Seite an diesr Stelle! Es hat mir wirklich sehr weitergeholfen und ich finde, dies sollte mehr aufmerksamkeit verdienen. TipTop
Pingback:cisco router wo find ich die daten login Page Info & Instructions Online User Account Activation - Odollars