R33NET BLOG Rotating Header Image

Cisco Switch-Konfiguration „Befehle/Commands“

Cisco Switch-Konfiguration „Befehle/Commands“ deutsch

 

Die wichtigsten Befehle zur Switchkonfiguration mit Erläuterung.

Switches (Standardkommando vor Verlassen)  
copy running-config startup-config Kopiert Konfiguration aus RAM in FLASH
Hostname  
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#hostname switch1 Setzt den Hostnamen
Benutzer anlegen
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#username NUTZER password PW Legt NUTZER mit Kennwort PW an
SSH
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#ip domain-name domae.ne Erzeugt den Domänennamen domä.ne
(config)#line vty 0 4 Wechselt zu den vty lines 0 bis 4
(config-line)#login local Lokale Nutzer und Kennworte werden verwendet
(config-line)#transport input telnet ssh Aktiviert den SSH und Telnet Zugang auf den VTYs
(config-line)#exit Verlässt das Submenü
(config)#crypto key generate rsa Aktiviert SSH und erzeugt ein RSA Schlüsselpaar
Telnet-Passwort
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#line vty 0 4 Wechselt zu den vty lines 0 bis 4
(config-line)#password tel_pw Setzt das Telnet Kennwort
(config-line)#login Aktiviert die Kennwortabfrage
Konsolen-Passwort
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#line console 0 Wechselt zum Konsolenzugang
(config-line)#password con_pw Setzt das Konsolenkennwort
(config-line)#login Aktiviert die Kennwortabfrage
Enable Password & Secret
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#enable password cisco1 Setzt das unverschlüsselte Enable Kennwort
(config)#enable secret cisco Setzt das verschlüsselte Enable Secret
VLANS definieren (1)
>enable Wechselt in den privileged mode
#VLAN database Wechselt in das VLAN Submenü
(vlan)#VLAN2 name VLAN 2 Legt VLAN2 mit dem Namen VLAN2 an
VLANS definieren (2)
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#vlan 2 Legt VLAN2 an und wechselt in VLAN Submenü
(config-vlan)#name VLAN2 Bennent das VLAN
VLANS adressieren
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#int vlan2 Wechselt zum Interfacce VLAN 2
(config-if)#ip add 192.168.11.2  255.255.255.0 Definiert IP auf VLAN2
(config)#int vlan3 Wechselt zum Interfacce VLAN 3
(config-if)#ip add 192.168.11.3  255.255.255.0 Definiert IP auf VLAN3
(config)#int vlan4 Wechselt zum Interfacce VLAN 4
(config-if)#ip add 192.168.11.4  255.255.255.0 Definiert IP auf VLAN4
* Der no shutdown Befehl sollte nur auf dem Administrativen VLAN gesetzt werden.
VTP Operationen
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#vtp mode server Setzt den VTP Modus auf Server*
ODER * VLAN Informationen werden verteilt, auch neue VLANS
(config)#vtp mode client Setzt den VTP Modus auf Client**
ODER **VLAN Informationen werden angenommen, aber nicht gespeichert
(config)#vtp mode transparent Setzt den VTP Modus auf Transparent***
***VLAN Informationen werden weitergeleitet und gespeichert,neue VLANS nicht
(config)#vtp domain TESTDOM Setzt die VTP Domäne auf TESTDOM
(config)#vtp domain password vtp_pw Setzt das Domänenkennwort
VLAN an Interface binden
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#int fa 0/5 Wechselt zum Interface
(config-if)#switchport access vlan2 Bindet VLAN2 an Interface
(config-if)#no shut Fährt Interface hoch
(config)#int fa 0/6 Wechselt zum Interface
(config-if)#switchport access vlan3 Bindet VLAN3 an Interface
(config-if)#no shut Fährt Interface hoch
Interface Modus setzen
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#int fa 0/5 Wechselt zum Interface
(config-if)#switchport mode trunk Versetzt das Interface in den Trunk-Modus
ODER
(config-if)#switchport mode access Versetzt das Interface in den Access-Modus*
ODER *(für Endgeräte verwenden)
(config-if)#switchport mode dynamic auto Interface verhandelt mit Gegenstelle über Modus**
ODER ** (wenn beide Seiten auf Auto stehen wird kein Trunk geformt)
(config-if)#switchport mode dynamic desirable Interface verhandelt mit Gegenstelle über Modus***
***(Trunk-Modus wird vorgeschlagen)
(config-if)#spanning-tree portfast Aktiviert Portfast auf dem Interface (Nur auf IFs zu Hosts setzen)
ODER
(config-if)#spanning-tree portfast default Deaktiviert Portfast
Port Security
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#int fa 0/5 Wechselt zum Interface
(config-if)#switchport port-security mac-address sticky „Klebt“ die erste empfangene MAC an das Interface
ODER
(config-if)#switchport port-security mac-address MAC Bindet die MAC an das Interface
(config-if)#switchport port-security violation shutdown Definiert shutdown als Aktion bei Fehlerhafter MAC*
ODER * Standard Einstellung
(config-if)#switchport port-security violation protect Definiert Protect als Aktion bei Fehlerhafter MAC**
ODER ** Frame wird verworfen, aber keine Log-Meldung
(config-if)#switchport port-security violation restrict Definiert Restrict als Aktion bei Fehlerhafter MAC**
*** Frame wird verworfen & Log-Meldung
(config-if)#switchport port-security maximum 2 Definiert Zahl der MAC, die an Interface gebunden werden können
(config-if)#switchport port-security Aktiviert Port Security
Etherchannel
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#interface range fa 0/1 – 4 Wechselt zur Range Fastethernet Port 1 – 4
(config-if-range)#channel-group 1 mode on Aktiviert auf der Range den Etherchannel 1
DNS Nutzung
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#no ip domain-lookup Deaktiviert DNS Anfragen
ODER
(config)# ip domain-lookup Aktiviert DNS Anfragen
Kennwortverschlüsselung
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#service password-encryption Gesetzte und zukünftige Kennworte werden verschlüsselt hinterlegt
ODER
(config)#no service password-encryption Kennworte werden unverschlüsselt hinterlegt
Spanning Tree
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#spanning-tree vlan 2 priority 4096 Setzt die Bridge Priorität für VLAN 2 auf 4096 (immer ein Vielfaches)
(config)#spanning-tree mode pvst Aktiviert den PerVlanSpanningTree
ODER
(config)#spanning-tree mode rapid-pvst Aktiviert den PerVlanRapidSpanningTree
ODER
(config)#spanning-tree mode mst Aktiviert den MultipleInstancesSpanningTree
HTTP aktivieren (CMD/SMD)
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#ip http server Aktiviert den HTTP-Server auf dem Gerät
(config)#ip http server secure Aktiviert den Secure HTTP-Server (SSL) auf dem Gerät
CDP
>enable Wechselt in den privileged mode
#conf t Wechselt in den globalen Konfigurationsmodus
(config)#cdp run Globale aktivierung von cdp
(config)#int fa 0/3 Wechselt zum Interface
(config-if)#cdp enable Aktiviert CDP auf Interface
(config-if)#cdp timer Sendeintervall von CDP-Messages
(config-if)#cdp holdtime Paket-halte-Zeit von CDP
STRG+Z Wechselt zum privileged mode
#clear cdp table Leert die CDP Einträge
Show Befehle
>enable Wechselt in den privileged mode
#show running-config Zeigt die aktuelle Konfiguration
#show version Zeigt die aktuelle IOS Version
#show ip interface brief Liefert einen globale Überblick über die Interfaces
#show ip interface status Liefert eine Statusübersicht der Interfaces
#show ip interface fastethernet 0/1 Zeigt Informationen zum Interface fastethernet 0/1
#show vlan (database) Zeigt Informationen zu den Vlans (alter Befehl)
#show vlan brief Globale Informationen zu den VLANS
#show vlan status Statusinformationen zu den VLANS
#show vlan id 2 Zeigt nur von VLAN 2 Informationen, nach id
#show vlan name vlan0002 Zeigt nur von VLAN 2 Informationen, nach name
#show spanning-tree Liefert detailierte Informationen zum STP
#show users Zeigt angemeldete Nutzer
#show sessions Zeigt aktive Sitzungen
#show cdp CDP Status Informationen
#show cdp traffic CDP Traffic Informationen
#show cdp neighbors CDP Nachbar Informationen
#show cdp entry CDP Geräte Eintrag
#show cdp interface CDP Interface Informationen
#show etherchannel Zeigt Informationen zu allen Etherchannels

2 Comments

  1. Patrick sagt:

    Good work! Thank you!!!!

Schreibe einen Kommentar